【拓扑图】:
【实验命令描述】:用 silent-interface 命令来禁止接口发送 OSPF 报文。缺省情况下,允许接
口发送 OSPF 报文。禁止接口发送 OSPF 报文后,它将成为被动接口(Passive interface)不再发送 Hello 报文。如果要使 OSPF 路由信息不被某一网络中的路由器获得,可使用本命令禁止在此接口上发送 OSPF 报文。
【实验配置】:
[rt0]:
#
interface Serial0/2/0
link-protocol ppp
ip address 11.11.11.1 255.255.255.0
#
interface Serial0/2/1
link-protocol ppp
ip address 13.13.13.1 255.255.255.0
#
ospf 1
area 0.0.0.0
network 11.11.11.0 0.0.0.255
network 13.13.13.0 0.0.0.255
#
[rt1]:
#
interface Serial0/2/0
link-protocol ppp
ip address 12.12.12.1 255.255.255.0
#
interface Serial0/2/1
link-protocol ppp
ip address 11.11.11.2 255.255.255.0
#
interface LoopBack1
ip address 1.1.1.1 255.255.255.255
#
ospf 1
silent-interface Serial0/2/0
area 0.0.0.0
network 1.1.1.1 0.0.0.0
network 11.11.11.0 0.0.0.255
network 12.12.12.0 0.0.0.255
#
[rt2]:
#
interface Serial0/2/0
link-protocol ppp
ip address 12.12.12.2 255.255.255.0
#
interface Serial0/2/1
link-protocol ppp
ip address 13.13.13.2 255.255.255.0
#
ospf 1
silent-interface Serial0/2/0
area 0.0.0.0
network 13.13.13.0 0.0.0.255
network 12.12.12.0 0.0.0.255
#
做静默端口前的路由表:
[rt2]dis ip routing-table
做静默端口后的路由表:
[rt2]dis ip routing-table