1021 个位数统计
输入格式: 每个输入包含 1 个测试用例,即一个不超过 1000 位的正整数 N。
输出格式: 对 N 中每一种不同的个位数字,以 D:M 的格式在一行中输出该位数字 D 及其在 N 中出现的次数 M。要求按 D 的升序输出。
输入样例:
100311
输出样例:
0:2
1:3
3:1
思路:用string进行读入,然后遍历字符串,用map<int,int>进行存贮每个字符有多少个。输出即可(map会根据first的值自动排序)。
code:
#include<bits/stdc++.h>
using namespace std;
map<int,int> mp;
int main(){
string s;
cin>>s;
int l = s.size();
for(int i=0;i<l;i++){
mp[s[i]-'0']++;
}
for(auto it = mp.begin();it!=mp.end();it++){
cout<<it->first<<":"<<it->second<<endl;
}
return 0;
}