G 公司有 n 个沿铁路运输线环形排列的仓库,每个仓库存储的货物数量不等。
如何用最少搬运量可以使 n 个仓库的库存数量相同。
搬运货物时,只能在相邻的仓库之间搬运。
数据保证一定有解。
输入格式 第 1 行中有 1 个正整数 n,表示有 n 个仓库。
第 2 行中有 n 个正整数,表示 n 个仓库的库存量。
输出格式 输出最少搬运量。
数据范围 1≤n≤100, 每个仓库的库存量不超过 100。
输入样例:
5
17 9 14 16 4
输出样例:
11
#include<bits/stdc++.h>
using namespace std;
const int N = 110;
const int M = 4 * (50 * 50 + 400);
const int INF = 0x3f3f3f3f;
int n,m,s,e;
struct Edge{
int v,next,w,f;
}edge[M];
int head[N],cnt = 0;
void add(int u,int v,int f,int w){
edge[cnt].v = v;
edge[cnt].w = w;
edge[cnt].f = f;
edge[cnt].next = head[u];
head[u] = cnt ++;
}
int w[N];
int q[N],hh = 0,tt = 0,pre[N],curf[N],st[N],d[N];
bool spfa(){
//最大流最大费用的话就求最长路即可
memset(d,0x3f,sizeof d);
memset(curf,0,sizeof curf);
memset(st,0,sizeof st);
hh = tt = 0;
d[s] = 0,q[tt ++] = s,curf[s] = INF;
st[s] = true;
while(hh != tt){
int t = q[hh ++];
if(hh == N)hh = 0;
st[t] = false;
for(int i = head[t];~i;i = edge[i].next){
int v = edge[i].v,w = edge[i].w;
if(edge[i].f && d[v] > d[t] + w){
d[v] = d[t] + w;
pre[v] = i;
curf[v] = min(edge[i].f,curf[t]);
if(!st[v]){
q[tt ++] = v;
if(tt == N)tt = 0;
st[v] = true;
}
}
}
}
return curf[e] > 0;
}
void EK(int &flow,int &cost){
flow = cost = 0;
while(spfa()){
int t = curf[e];
flow += t;cost += t * d[e];
for(int i = e;i != s;i = edge[pre[i] ^ 1].v){
edge[pre[i]].f -= t,edge[pre[i] ^ 1].f += t;
}
}
}
int main(){
cin>>n;
s = 0,e = n + 1;
int x;
memset(head,-1,sizeof head);
int res = 0;
for(int i = 1;i <= n;i ++){
cin>>w[i];
res += w[i];
}
int _x = res / n;
for(int i = 1;i <= n;i ++){
if(w[i] > _x){
add(s,i,w[i] - _x,0);
add(i,s,_x - w[i],0);
for(int j = 1;j <= n;j ++){
int t = min(abs(i - j),n - abs(i - j));
add(i,j,INF,t);
add(j,i,0,-t);
}
}
else {
add(i,e,_x - w[i],0);
add(e,i,w[i] - _x,0);
}
}
int flow = 0,cost = 0;
EK(flow,cost);
cout<<cost<<endl;
return 0;
}
发布者:全栈程序员栈长,转载请注明出处:https://javaforall.cn/168566.html原文链接:https://javaforall.cn