任务是编写一个简单的程序,如果输入的是偶数,则获取一个整数并计算其阶乘,如果输入的是奇数,则检查该数字是否为质数。程序重复进行,直到输入值"-6.5“。我添加了一个条件,使循环在输入该值时停止,但是当输入该值(或任何其他小数)时,我会得到输入提示的无限重复循环。为什么会发生这种情况? #include <iostream>
using namespace std;
int main ()
{
int num;
do
{
int choice;
int factorial=1;
int count=0;
cout<
我正在尝试创建一个while循环,您可以在其中输入任意数量的整数。只有当我输入数字0时,输入才会被求和和打印。
目前,我写了以下几篇文章:
n = int(input())
sum = 0
while n != 0:
sum = sum + n
print(sum)
当我输入0值时,循环不会关闭,我的和也不会被打印出来。
我遗漏了什么吗?
提前谢谢你!
当我输入0时,我期望循环关闭,这将给出以前输入的所有数字的和。
例如:
Input:
2
3
1
0
Output:
6
数字不能被接受到输入中,而只能接受字母。
ans = str(input('Select an option?'))
if ans=="A":
if len(array) < 10:
A = list(input('\nInput string: \n'))
while True:
try:
A = list(input('\nInput string: \n'))
if A not in (1,
如果我输入数字,一切都很正常。如果我输入字母,程序将不再工作。我做错了什么? 附注:然后我将以函数的形式连接其他程序,我希望它们能够从菜单运行,然后再次返回到选择菜单 #define _CRT_SECURE_NO_WARNINGS
#include <stdio.h>
main ()
{
int a;
do {
printf("Enter number of programm: \n 1) First programm \n 2) Second programm \n 3) Third programm \n ");
scanf
使用do...while()循环需要连续扫描用户输入的随机整数,并打印出每行分隔的平方。一旦输入值为0,它仍将打印出其平方值,但随后应终止循环。 这是示例输入: 2,6,0 这是示例输出: 4,36,0 这是我到目前为止的代码: #include <stdio.h>
int main() {
int a;
int num;
int b;
do {
scanf("%d", &a);
} while (a != 0);
while (a > num) {
num++;
if (num == a) {
基本上,我试图把价格乘以数量,但这是行不通的。我知道这个错误:
{“输入字符串格式不正确”}
感谢您的帮助,提前感谢。
这些数据存储在我想要驱动和乘的cookie中。
new DataColumn("quantity"), new DataColumn("Price") //and its basically stored in a cookie
int tot;
tot = tot + (Convert.ToInt32(a[4].ToString()) * Convert.ToInt32(a[5].ToString()));
Bellow是调试结果的屏
我尝试获取用户输入(整数),直到她输入‘end’(字符串)。我正在尝试下面的代码,但它只存储在数组中输入的备用数字。请提个建议。
Scanner sc = new Scanner(System.in);
List<Integer> al = new ArrayList<Integer>();
System.out.println("Enter 'end' to stop input");
while(!sc.next().eq
我想使用infile语句来读取和显示如下数字-
0.02133322413531
25895449673.5189
190848802804.89248974
不从平面文件中丢失任何数字(显着数字和非显着数字),这些数字是用于输入、格式和格式的最佳格式。
编辑:
到目前为止已经尝试过了,最后一个数字被截断了,剩下的两个就好了。
data _null_;
infile datalines;
format x BEST32.;
input x : BEST32.;
put x=;
datalines;
0.02133322413531
25895449673.5189
1908
#include <iostream>
using namespace std;
void check_positive () {
cout << "Number given must be positive. Please try again." << endl;
}
int main() {
int pesos, interest, compound, year;
do {
cout << "How many pesos did you deposit? ";
我有这个程序:
def test(zeit_1, zeit_2):
zeit_1_liste = [int(x) for x in str(zeit_1)]
zeit_2_liste = [int(x) for x in str(zeit_2)]
print(zeit_1_liste, zeit_2_liste)
print(test(160606,240000))
此程序将int转换为数字列表。虽然当输入以>=1开始时,如果输入数字以0开始(例如060606和092618),它会很好地工作,但它会给我一个无效的令牌错误。
我该如何