我在一个文件中存储了以下命令集
ip ospf db area 0.0.0.0 rtr <ip> adv <ip>
ip ospf db area 0.0.0.0 rtr <ip> self-originate
ip ospf db area 0.0.0.0 rtr <ip>
ip ospf db area 0.0.0.0 rtr adv <ip>
ip ospf db area 0.0.0.0 rtr orig
ip ospf db area 0.0.0.0 rtr
需要用以下命令替换上面的命令集:-
ip ospf db
请帮帮忙。我要显示输出
interface vlan1 is not configured with ospf
interface vlan3 is configured with ospf
interface vlan7 is configured with ospf
但是我在运行下面的脚本时得到的输出是
interface vlan1 interface vlan3 interface vlan7 is configured with ospf
$interface = select-string -path c:\doc\config.txt -pattern "interfa
获取AnsibleError:模板化字符串时出现模板错误:应为标记'end of statement block',获取的是'{‘ 这是我的jinja2模板,有人能帮我找出哪里出了问题吗? no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
我正在使用Juniper系列路由器来模拟一个小型电信和VPN用户,我需要使用OSPF,以便路由信息可以传播到所有P和PE节点(基本上都是核心路由器和边缘路由器).Note,我不希望路由信息被传递给面向客户的路由器(绿色路由器)。
TAU-PE1:
set protocols ospf area 0.0.0.0 interface ge-0/0/0
set protocols ospf area 0.0.0.0 interface ge-0/0/1
set protocols ospf area 0.0.0.0 interface lo0.0 passive (loopback)
set pr
这是一个我在网上看到的混合答案的问题,所以我将尝试清楚地解释我在理解什么方面有困难。有了RIP,您就拥有了路由器,并且明确地告诉它您直接连接的网络如下:
network [network address of the network linking the two routers]
然而,据我所知,OSPF并没有这样做。相反,您可以像这样为OSPF配置接口:
network [address of Serial 0 (for example)] [wildcard address] area [X]
因此,我的问题是:如果您正在配置接口而不是网络,OSPF是如何理解两个路由器之间的网络的?
我
假设我在Cisco的IOS中使用以下命令配置OSPF:
router ospf 201
network 10.0.0.0 0.255.255.255 area 10.0.0.0
network 192.168.0.0 0.0.255.255 area 0
我如何随后列出定义的网络区域?例如,假设我输入了一个错误并发出了一个“无网络”命令,我如何知道之前输入了什么?
编辑:我运行了“显示ip ospf”并获得了以下输出:
router#show ip ospf
Routing Process "ospf 1" with ID 10.0.0.1
Supports only sing
我有一个运行quagga0.98.2的Centos 5盒,它用以下内容淹没了ospfd.log:
OSPF: Link State Update: LSA checksum error 2a32, 58d5.
OSPF: Link State Update: LSA checksum error 2a32, 63bf.
OSPF: Link State Update: LSA checksum error 2a32, 63bf.
OSPF: Link State Update: LSA checksum error 2a32, 63bf.
OSPF: Link State Update: LS
我试着用两个空行来拆分段落。我尝试使用String.split()、StringTokenizer和StringUtils类,但都不起作用。
下面是我的代码:
DeviceNames (interfacename) # show commands
Codes: K - kernel, C - connected, S - static, R - RIP, B - BGP
O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 -
路由器与ASBR2连接到区域0和10,ASBR1连接到区域0和20,R1's路由表中没有路由入口,帮助我走出
R1#sh run
Building configuration...
Current configuration : 1080 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R1
!
!
!
!
!
!
!
!
ip cef
no
我们已经在路由器上设置了OSPF并开始选择ip地址70.xx.xx.33,但是后来我们删除了那些IP并为新子网重新配置,但有时OSPF仍然显示较老的路由器ID -看到路由器ID中较旧的IP地址,有什么方法可以告诉OSPF重新初始化新ID而不重新加载?
R1#sh ip ospf summary-address
OSPF Router with ID (70.xx.xx.33) (Process ID 1)
编辑:
它的思科C3850 L3开关与最新的IOS运行。
我试图从键'ip‘中提取一个特定的值,在这个例子中,它是192.168.200.200,但在某些情况下,它将是不同的,可能不止一个。我是刚接触python的人,有人能帮我拿出价值吗?
# import functions
from cisco_xe_api import *
# define variables
device_config = api_get_conf()
# Rule SV-105995r2_rule: The Cisco router must be configured to implement message
# authentication for all