数据库配置 1.宝塔控制面板-软件商店-MySql-设置 2.点击配置修改,查找sql-mode或sql_mode (可使用Ctrl+F快捷查找) 3.复制 NO_AUTO_CREATE_USER...,NO_ENGINE_SUBSTITUTION 然后替换粘贴,保存 4.重启MySQL 注: MySQL8.0版本的 第三步用 sql_mode=NO_ENGINE_SUBSTITUTION
主键(PRIMARY KEY 约束):PRIMARY KEY 约束唯一标识数据库表中的每条记录。 主键就是唯一的,其是索引的一种,并且是唯一性索引的一种。...其实主键就像我们的身份证一样,每一个主键的id就表示着一个特定的一个行,或者说那一行信息,那一行数据。我们select查询数据,如果我们知道主键是多少,那么我们直接加到where条件就ok了。...创建表的时候如下创建主键约束: CREATE TABLE test2231 ( age INT(10), sex VARCHAR(10), name11 VARCHAR(10) NOT...NULL, CHECK (age>0), UNIQUE (age), PRIMARY KEY(age) ) 其中最后一行就是我们的主键约束创建的方法。
表中的任何列都可以作为主键,只要它满足以下条件: 1、任何两行都不具有相同的主键值 2、每个行都必须具有一个主键值(主键列不允许NULL值) 除MySQL强制实施的规则外,应该坚持的几个普遍认为的最好习惯为...: 1、不更新主键列的值 2、不重用主键列的值 3、不在主键列中使用可能会更改的值(例如,如果使用一个名字作为主键以标识某个供应商,应该供应商合并和更改其名字时,必须更改这个主键) 总之:不应该使用一个具有意义的...这就要求同一个叶子节点内(大小为一个内存页或磁盘页)的各条数据记录按主键顺序存放,因此每当有一条新的记录插入时,MySQL会根据其主键将其插入适当的节点和位置,如果页面达到装载因子(InnoDB默认为15...2、.如果使用非自增主键(如果身份证号或学号等),由于每次插入主键的值近似于随机,因此每次新纪录都要被插到现有索引页得中间某个位置: 此时MySQL不得不为了将新记录插到合适位置而移动数据,甚至目标页面可能已经被回写到磁盘上而从缓存中清掉...如果没有显式地在表定义时指定主键,InnoDB存储引擎会为每一行生成一个6字节的ROWID,并一次作为主键。 mysql 在频繁的更新、删除操作,会产生碎片。而含碎片比较大的表,查询效率会降低。
1问题背景 同事咨询了一个问题,TDSQL(for MySQL)中的某张表主键需要改为联合主键,是否必须先删除现有的主键?因为删除主键时,提示这个错误。...解决方案是增加主键或者删除此参数避免错误,同时提醒了,如果表无主键,可能会导致基于行的复制产生性能问题。 sql_require_primary_key 参数控制的是强制检查主键,可以动态修改。...参数名称:sql_require_primary_key 作用范围:Global & Session 动态修改:Yes 默认值:OFF 该参数设置为 ON 时,SQL 语句 create table 创建新表或者...alter 语句时,对已存在的表进行修改,将会强制检查表中是否包含主键,如果没有主键,则会报错。...参数控制了强制检验主键,而且又是可动态修改的,临时关闭,再打开即可。
SQL中主键的约束 if exists(select * from sys.databases where name='SchDB') drop database SchDB create database...S_id) ) --创建唯一约束 create table K1(name nvarchar(20) unique) create table K3( id int not null,--如果是主键必须添加...not null name nvarchar(20) constraint UQ_Name2 unique ) --修改表创建约束 alter table K3 add constraint
(比如: 几百万的记录),使用insert语句插入性能较低,此时可以使用MySQL数据库提供的load指令进行插入。...`username`) ) ENGINE = INNODB DEFAULT CHARSET = utf8; 2、设置参数 -- 客户端连接服务端时,加上参数 -–local-infile mysql...尽量不要使用UUID做主键或者是其他自然主键,如身份证号。 业务操作时,避免对主键的修改。...在MySQL8版本中,支持降序索引,我们也可以创建降序索引。...create index idx_user_sex_birthday_ac on tb_user(sex asc ,birthday desc ); 然后再执行SQL语句查询。
Sql代码 mysql> create database ssh2; Query OK, 1 row affected (0.04 sec) mysql> use ssh2; Database... changed mysql> create table user( -> id integer primary key, -> firstname varchar(200)...lastname varchar(200) not null, -> age integer -> ); Query OK, 0 rows affected (0.46 sec) 给主键增加一个自增的功能...: Java代码 mysql> alter table user modify id integer auto_increment ; Query OK, 1 row affected (0.28... sec) Records: 1 Duplicates: 0 Warnings: 0 这样,上面的user表里面的主键,id可以自增了。
表中的任何列都可以作为主键,只要它满足以下主键值规则条件: 任两行不具相同的主键值 每行都必须具有一个主键值(主键列不允许NULL) 这里的规则是MySQL本身强制实施的。...除MySQL强制实施的规则外,还应该坚持的最佳实践: 不更新主键列中的值 不重用主键列的值 不在主键列中使用可能会更改的值 例如,如果使用一个名字作为主键以标识某个供应商,当该供应商合并和更改其 名字时...,必须更改这个主键) 联合主键 好处 可以直观的看到某个重复字段的记录条数 主键A跟主键B组成联合主键 主键A跟主键B的数据可以完全相同,联合就在于主键A跟主键B形成的联合主键是唯一的。...联合主键体现在多个表上,复合主键体现在一个表中的多个字段。 复合主键 主键通常定义在表的一列上,但这并不是必需的,也可使用多个列作为主键。...表的主键含有一个以上的字段组成,不使用无业务含义的自增id作为主键 将多个字段设置为主键,形成复合主键,这多个字段联合标识唯一性,其中,某几个主键字段值出现重复是没有问题的,只要不是有多条记录的所有主键值完全一样
主键设计和应用原则 除了满足MySQL强制实施的规则(主键不可重复;一行中主键不可为空)之外,主键的设计和应用应当还遵守以下公认的原则: 不更新主键列中的值; 不重用主键列的值; 不在主键列中使用可能会更改的值...2、对数据库有依赖,每种数据库可能实现不一样,数据库切换时候,涉及到代码的修改,不利于扩展 结论: 自增id做主键适用于非分布式架构。...关于MySQL 使用自增ID主键和UUID 作为主键的性能比较可以查看参考【8】。 结论: 1、uuid做主键适用于小规模分布式架构用。...2、在使用uuid作为主键的时候,最好设计createtime(创建时间)列和modifytime(修改时间)列以应付可能的排序等场景。...结论: 用自建的id生成器做主键适用于大规模分布式架构 参考: 【1】:红心李 :MySQL主键设计 【2】:Uncle Nucky :MySQL数据库主键设计原则 【3】:ellis:设计套路:Mysql
MySQL主键约束是一种用于确保表中每行数据的唯一性的限制。每个表只能有一个主键,它可以是一个或多个列。创建表时添加主键约束在创建表时添加主键约束,需要在列名后面添加关键字"PRIMARY KEY"。...在已经存在的表中添加主键约束如果已经存在一个表,但需要将某些列或字段添加主键约束,可以使用ALTER TABLE语句来修改表结构。...需要注意的是,在修改表结构时,必须将该列中已经存在的值都设置为唯一,否则会出现错误。主键约束和自增列通常情况下,主键约束通常与自增列一起使用。自增列是指在插入新行时,自动为该行分配一个唯一的值。...在MySQL中,可以使用AUTO_INCREMENT关键字来创建自增列。...这意味着在插入数据时,无需提供"id"列的值,MySQL会自动为其分配一个唯一的值。示例假设有一个用户表,其中包含以下列:id、name和email。
介绍一下在phpmyadmin下如何设置主键、删除主键。...如果字段已经建好,可以用以下命令来设置主键,当然前提是id为自增字段,一般设置为int数据类型,主键建议使用bigint类型,如果是其他数据类型的话设置为主键会报错。...ALTER TABLE `tmp2` ADD PRIMARY KEY( `id`); 也可以通过phpmyadmin界面进行操作,可以选择数据表,选择“结构”,选取需要设置主键的字段,点击“主键”即可完成设置...设置好主键以后,可以看到主键名称后面有一把黄色的钥匙,鼠标移动上去会有“主键”的提示字样。下面也会显示有一个主键的键名“PRIMARY”。...如果要删除上面的主键约束,可以直接点击上图下方的“删除”,修改主键可以选择“编辑”更改其他字段为主键。
修改字段名称 alter table xgj rename column old_name to new_name; ---- 修改字段类型 alter table tablename modify...); Table altered 3、字段有数据,当修改后的类型和原类型不兼容时 ,执行时会弹出:“ORA-01439:要更改数据类型,则要修改的列必须为空” 栗子: --建表 create table...,可以直接modify修改。...2、当字段有数据并用要修改的新类型和原类型不兼容时,要间接新建字段来转移。...(1)无命名 可用 SELECT * from user_cons_columns; 查找表中主键名称得student表中的主键名为SYS_C002715 alter table student
修改mysql登录密码: 在使用数据库服务器过程中可能会因为种种原因忘记了登录密码,或者需要使用别人的数据库服务器,别人却忘记了登录密码等等。...忘记密码有两种方式可以解决,一是通过sql语句修改登录密码: ?...二是通过修改mysql 安装目录下的my.ini配置文件,在配置文件中找到[mysqld],然后在下面写上一句:sikp-grant-tables。...Sql语句类型: DDL:结构创建语句,能够创建、删除、修改、索引、视图、存储过程,塑造结构 DML:数据更新语句,专门操作数据,而且操作有限,基本操作表格里面的数据。...主键的意义在于给我们建立数据的目录,以后进行删除,添加,修改,单个查询等,就可以按照主键来进行操作。因为主键的值是唯一的,所以进行操作起来的速度要快得多。 代码示例: ?
前言 近期多次聊到sql_mode的话题,也是多次遇到相关问题,今天就趁热打铁,再给大家带来一个sql_mode的案例分享。...> delimiter ; (2)客户侧开发童鞋调用该存储过程,报错ERROR 1140;因为当时存储过程比较复杂,改造起来比较麻烦,所以客户侧选择修改sql_mode session 1: mysql...=only_full_group_by (3)客户侧修改完sql_mode,再次执行,发现仍然报错ERROR 1140 session 2: mysql> set global sql_mode='STRICT_TRANS_TABLES...=only_full_group_by (4)此时想到,修改系统变量,只对新建连接有效,对已有连接不起作用;于是,让客户侧重新建立连接,确认系统变量已生效,再次调用存储过程,但仍然报错ERROR 1140...,重复尝试几次都是这个结果 session 3: mysql> show variables like 'sql_mode'; +---------------+--------------------
表结构 image.png 创建表sql CREATE TABLE `users` ( `class_id` int NOT NULL, `user_id` int NOT NULL, `user_name...NULL, PRIMARY KEY (`class_id`,`user_id`) ) ENGINE=InnoDB DEFAULT CHARSET=utf8mb3; 表数据 image.png 插入表数据sql...-- 查询班级1,用户1和3 select * from `users` where `class_id` = 1 and `user_id` in(1,3); 复合主键的多条件批量删除...-- 刪除班级2,用户1和3 delete from `users` where `class_id` = 2 and `user_id` in (1,3); 复合主键的多条件批量修改...-- 修改班级3,用户1,3的money都为200 update `users` set money_out=200 where `class_id` = 3 and `user_id
测试必备的Mysql常用sql语句系列 https://www.cnblogs.com/poloyy/category/1683347.html 前言 update 也是DML语句哦(数据操作语言) update...的语法格式 UPDATE SET 字段1=值1 [,字段2=值2… ] [WHERE 子句 ] [LIMIT 子句] 语法格式说明 多指定多个字段,需要用 隔开 , 如果修改的字段有默认值...,可以用 default 来设置字段的值,如: ,这样就会把字段的值修改成默认值 name =default where 就不用多说了,一般 update 数据都会指定条件 添加 limit 是为了限制被修改的行数...修改单个字段的栗子 UPDATE emp SET is_enable = 0 WHERE id = 1 修改多个字段的栗子 UPDATE emp SET is_enable = 0, NAME...= "修改的名字", dept_id = 2 WHERE id = 1
MySQL为什么需要主键主键表中每一行都应该有可以唯一标识自己的一列(或一组列)。一个顾客可以使用顾客编号列,而订单可以使用订单ID,雇员可以使用雇员ID或雇员社会保险号。...表中的任何列都可以作为主键,只要它满足以下条件:任何两行都不具有相同的主键值。每个行都必须具有一个主键值(主键列不允许NULL值)这里列出的条件是MySQL本身强制实施的。...除MySQL强制实施的规则外,应该坚持的几个普遍认为的最好习惯为:不更新主键列的值。不重用主键列的值。不在主键列中使用可能会更改的值。比如用用户邮箱当主键,但是用户可能更换邮箱。...如果使用非自增主键:由于每次插入主键的值近似于随机,因此每次新纪录都要被插到现有索引页得中间某个位置:此时MySQL不得不为了将新记录插到合适位置而移动数据。...如果没有显式地在表定义时指定主键,InnoDB存储引擎会为每一行生成一个6字节的ROWID,并一次作为主键。MySQL在频繁的更新、删除操作时,会产生碎片。而含碎片比较大的表,查询效率会降低。
本篇讲解 Mysql 的「主键」问题,从「为什么」的角度来了解 Mysql 主键相关的知识,并拓展到主键的生成方案问题。再也不怕被问到 Mysql 时只知道 CRUD 了。...这就要求同一个叶子节点内(大小为一个内存页或磁盘页)的各条数据记录「按主键顺序存放」,因此每当有一条新的记录插入时,MySQL 会根据其主键将其插入适当的节点和位置,如果页面达到装载因子(InnoDB...否则由于每次插入主键的值近似于随机,因此每次新记录都要被插到现有索引页的中间某个位置,MySQL 不得不为了将新记录插到合适位置而「移动数据」,如下图右侧所示,这样就造成了一定的开销。...Key 时,就想先添加一条记录,之后再更新业务 Key 设计一个兼具易用和性能的 Key 生成方案比较难 逻辑 Key 的优点 不会因为业务的变动而需要修改 Key 逻辑 操作简单,且易于管理 逻辑...一般情况下,我们都使用 Mysql 的自增 ID,来作为表的「主键」,这样简单,而且从上面讲到的来看,性能也是最好的。
简忆上次所学知识:MySQL的记录长度为65535个字节,而varchar是达不到它的理论长度的,NULL占用一个字节,text文本不占用记录长度,因为它本身就占据十个字节。...这里继续学习与MySQL列属性相关知识:关于主键的增,改,删。...增加主键:SQL操作中有多种方式可以给表增加主键,大体上分为三种: 一.在创建表时,直接写在字段之后(优点:非常直接,缺点:只能使用一个字段作为主键) 相关语句: create table my_pril...三.当表已经创建好之后,额外追加主键:可以通过修改字段属性,也可以直接追加Alter table 表名 add primary key(字段列表); 前提:表中字段对应的数据本身是独立的(即不重复)...主键约束(修改数据) 主键对应的字段中的数据不允许重复:一旦重复,数据操作就会失败(增和改) 相关语句: -- 向表中插入数据 insert into my_pril values ('小明','itcast0001
mysql自增主键设置 在数据库应用中,经常希望在每次插入新纪录时,系统自动生成字段的主键值。可以通过为表主键添加AUTO_INCREMENT关键字来实现。...默认情况下,在MYSQL中AUTO_INCREMENT的初始值是1,每新增一条记录,字段值自动加1.一个表只能有一个字段属用AUTO_INCREMENT约束,且该字段必须为主键的一部分。