<div id="problemContent" style="margin: 0px; padding: 0px; border: 0px; font-stretch: inherit; line-height: 18px; font-family: 'Droid Sans', Verdana, 'Microsoft YaHei', Tahoma, sans-serif; vertical-align: baseline; color: rgb(51, 51, 51); background-color: rgb(250, 250, 250);"><p style="margin-top: 0px; margin-bottom: 1.5em; padding-top: 0px; padding-bottom: 0px; border: 0px; font-style: inherit; font-variant: inherit; font-weight: inherit; font-stretch: inherit;font-size:undefined; line-height: inherit; font-family: inherit; vertical-align: baseline;">读入n名学生的姓名、学号、成绩,分别输出成绩最高和成绩最低学生的姓名和学号。</p><p style="margin-top: 0px; margin-bottom: 1.5em; padding-top: 0px; padding-bottom: 0px; border: 0px; font-style: inherit; font-variant: inherit; font-weight: inherit; font-stretch: inherit;font-size:undefined; line-height: inherit; font-family: inherit; vertical-align: baseline;"><strong>输入格式:</strong>每个测试输入包含1个测试用例,格式为
</p><pre style="margin-top: 1.5em; margin-bottom: 1.5em; padding: 0px; border: 0px; font-stretch: normal; font-size: 1em; line-height: 1.5; font-family: 'Droid Sans Mono', Consolas, 'Courier New', monospace; vertical-align: baseline; overflow: auto;"> 第1行:正整数n
第2行:第1个学生的姓名 学号 成绩
第3行:第2个学生的姓名 学号 成绩
... ... ...
第n+1行:第n个学生的姓名 学号 成绩
其中姓名和学号均为不超过10个字符的字符串,成绩为0到100之间的一个整数,这里保证在一组测试用例中没有两个学生的成绩是相同的。
输出格式:对每个测试用例输出2行,第1行是成绩最高学生的姓名和学号,第2行是成绩最低学生的姓名和学号,字符串间有1空格。
输入样例:
3
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95
输出样例:
Mike CS991301
Joe Math990112
分析:
定义一个结构体保存学生信息, 定义两个指针分别指向最高分和最低分, 输入的时候逐个比较即可.,
代码:
<pre name="code" class="html">#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
struct inf {
char name[15];
char id[15];
int score;
};
int main() {
int n;
cin >> n;
inf stu[n];
inf *p = stu, *q = stu;
int max = 0, min = 100;
for ( int i = 0; i < n; i++ ) {
cin >> stu[i].name >> stu[i].id >> stu[i].score;
if ( stu[i].score > max ) {
max = stu[i].score;
p = &stu[i];
}
if ( stu[i].score < min ) {
min = stu[i].score;
q = &stu[i];
}
}
printf("%s %s\n%s %s\n", p->name, p->id, q->name, q->id);
return 0;
}
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
struct inf {
char name[15];
char id[15];
int score;
};
int main() {
int n;
cin >> n;
inf stu[n];
inf *p = stu, *q = stu;
int max = 0, min = 100;
for ( int i = 0; i < n; i++ ) {
cin >> stu[i].name >> stu[i].id >> stu[i].score;
if ( stu[i].score > max ) {
max = stu[i].score;
p = &stu[i];
}
if ( stu[i].score < min ) {
min = stu[i].score;
q = &stu[i];
}
}
printf("%s %s\n%s %s\n", p->name, p->id, q->name, q->id);
return 0;
}