前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >【PAT甲级】Longest Symmetric String

【PAT甲级】Longest Symmetric String

作者头像
喜欢ctrl的cxk
发布2019-11-08 14:36:03
3040
发布2019-11-08 14:36:03
举报
文章被收录于专栏:Don的成长史

版权声明:本文为博主原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。

代码语言:txt
复制
                 本文链接:[https://blog.csdn.net/weixin\_42449444/article/details/89459876](https://blog.csdn.net/weixin_42449444/article/details/89459876) 

Problem Description:

Given a string, you are supposed to output the length of the longest symmetric sub-string. For example, given Is PAT&TAP symmetric?, the longest symmetric sub-string is s PAT&TAP s, hence you must output 11.

Input Specification:

Each input file contains one test case which gives a non-empty string of length no more than 1000.

Output Specification:

For each test case, simply print the maximum length in a line.

Sample Input:

代码语言:javascript
复制
Is PAT&TAP symmetric?

Sample Output:

代码语言:javascript
复制
11

解题思路:

这道题在天梯赛出现过:【GPLT】L2-008 最长对称子串。用ans来记录最长对称子串的长度,然后从后往前找第一个相同的字符,找到后就用t2往前、t1往后来寻找对称子串,直到字符不相等或者t1、t2相遇为止。

AC代码:

代码语言:javascript
复制
#include <bits/stdc++.h>
using namespace std;

int main()
{
    string str;
    getline(cin,str);
    int len = str.length();
    int ans = 1;   //用来记录最长对称子串的长度
    for(int i = 0; i < len-1; i++)
    {
        for(int j = len-1; j >= i; j--)
        {
            if(str[i] == str[j])  //从后往前找第一个相同的字符
            {
                int t1 = i, t2 = j;
                bool flag = true;    //用来记录是不是对称字符串
                while(t1 <= t2)   //判断是不是对称字符串,t1往后,t2往前,直到t1,t2相遇为止
                {
                    t1++;
                    t2--;
                    if(str[t1] != str[t2])  //若不是对称字符串
                    {
                        flag = false;
                        break;
                    }
                }
                if(flag)
                {
                    ans = max(ans,j-i+1);
                }
            }
        }
    }
    cout << ans << endl;
    return 0;
}
本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
原始发表:2019/04/22 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • Problem Description:
  • Input Specification:
  • Output Specification:
  • Sample Input:
  • Sample Output:
  • 解题思路:
  • AC代码:
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档