首页
学习
活动
专区
圈层
工具
发布
  • 您找到你想要的搜索结果了吗?
    是的
    没有找到

    线上MySQL不可用,报错数据库无法连接

    但这时若MySQL报异常Too many Connections,说明目前MySQL无法建立400个网络连接。这也太少了吧,这可是高配置机器!...因为底层linux把进程可打开的文件句柄数限制为1024了,导致MySQL最大连接数是214! Linux文件句柄数量被限制也会导致MySQL最大连接数被限制。...此时再尝试业务系统去连接DB,就没问题了。 为何Linux最大文件句柄限制为1024时,MySQL最大连接数是214?MySQL源码中就是有个计算公式,算下来就是这样的结果。...因为若linux限制你一个进程的文件句柄太少,就会导致我们无法创建大量网络连接,我们的系统进程就无法正常工作。...比如Kafka之类的MQ,在生产环境部署时,若不优化linux内核参数,会导致Kafka可能无法创建足够的线程,此时也无法运行。

    4.3K20

    腾讯云主机中MySQL无法远程连接的解决办法

    在远程主机上,我开启了 mysql服务,用 phpmyadmin 可以打开,比如说用户名为 root,密码为 123456。...不过用 Mysql 客户端远程连接时却报了错误,比如 Mysql-Front 报了如下错误: Access denied for user ‘root’@’xxxxxx′(using password:...YES) 服务器是腾讯云 比较奇怪,phpmyadmin 可以正常访问,而 Mysql-Front 为什么无法连接呢?...可能的原因,应该就是 IP 限制了,phpmyadmin在连接时使用的是localhost,而我们访问页面才使用的远程主机的 IP,而 Mysql-Front 连接的是远程主机。...解决方法如下: 首先修改mysql的配置文件,my.cnf,将 #bind-address = 127.0.0.1 这一行注释掉,要不然它永远限制了只能本机连接。 然后重启mysql服务。

    20.2K00

    EasyCVR服务启动失败并报错“无法连接到MySQL”,如何解决?

    我们在此前的文章中和大家介绍过,我们的视频平台默认的数据库是SQlite,平台可支持用户将数据库替换为MySQL。关于数据库的迁移替换等操作教程,感兴趣的用户可以翻阅我们以往的文章进行了解。...有用户反馈,在使用时出现了EasyCVR启动失败的现象,并显示报错“无法连接到MySQL”,请求我们协助排查。今天来和大家分享一下排查及解决办法。...1)使用进程启动软件后,程序自动退出,我们来查看一下log日志:2)根据日志提供的信息(not allowed to connect to this MySQL server),是EasyCVR服务器连接不到...MySQL。...使用数据库软件测试,查看是否连接不通:3)尝试在MySQL内开通权限:4)更新权限后,再次连接,发现此时可以连接到MySQL了:5)尝试是否能正常启动EasyCVR服务:6)如上图所示,程序成功启动。

    3.3K20
    领券