首页
学习
活动
专区
圈层
工具
发布

nginx的安装与配置启动(linux)

nginx的安装与配置 首先明白nginx是干什么的,首先它是一款服务器,亲身体验非常轻量。按照一些专业的说法。...开发者伊戈尔·赛索耶夫 本文主要记录一下linux服务器配置nginx服务的一些主要的过程。 首先它是由c语言开发的,所以我们需要去安装一些它的编译环境。我们安装这个额服务是一定要经过编译的。...很简单在我们linux的根目录下面etc/profile,我们用命令进去去编辑这个文件配置 用编辑器打开来看下,这里下面的path就是用来配置环境变量的地方。...修改为82 其实在配置文件修改东西后,你可以去用命令查看配置是否正确 nginx -t 启动的话直接输入这个命令就好 nginx 我们可以用这个命令去查看nginx进程相关 ps -ef...--reload 现在哦们可以去访问nginx默认界面 服务器的话,就是外网ip加上端口 这样大概就是我们初次的配置以及命令启动以及访问,后面的话再展开说。

2.9K10
  • 您找到你想要的搜索结果了吗?
    是的
    没有找到

    Linux下的Nginx安装(开机自启动)

    copy压缩包至linux的相应目录,例如:opt下的software,需要确认当前登录用户有权限进行解压和安装。...大致意思是静态资源请求的处理方法中,如果发现请求方法为post提交则拒绝 接下来就是安装了 make && make install Nginx默认被安装在/usr/local/nginx 3)开机自启动...nginx/conf/nginx.conf nginxd=/usr/local/nginx/sbin/nginx nginx_config=/usr/local/nginx/conf/nginx.conf...   (a+x ==> all user can execute  所有用户可执行) 这样在控制台就很容易的操作nginx了:查看Nginx当前状态、启动Nginx、停止Nginx、重启Nginx… ?...同样的修改了nginx的配置文件nginx.conf,也可以使用上面的命令重新加载新的配置文件并运行,可以将此命令加入到rc.local文件中,这样开机的时候nginx就默认启动了 vi /etc/rc.local

    4.8K20

    Linux 普通用户启动nginx报错处理

    nginx 配置的user为 www 用户,root启动之后主进程显示root,子进程显示是www,但是切换到www 用户之后执行 nginx -t 等报错 /usr/local/nginx/sbin/.../conf/nginx.conf syntax is ok … 分析 nginx需要超级用户启动,因为普通用户只能用1024以上的端口,1024以内的端口只能由root用户使用,nginx这里使用的是...80端口,所以切换普通用户启动失败 方案 想到的第一反应就是让要保留80端口,只能是root启动,又想用普通用户启动怎么办呢?...分析 nginx需要超级用户启动, 因为普通用户只能用1024以上的端口,1024以内的端口只能由root用户使用,nginx这里使用的是80端口,所以切换普通用户启动失败 方案 要保留80端口,只能是...root启动,又想用普通用户启动怎么办呢?

    5.3K10

    Nginx学习日志(六)Linux下设置开机自启动

    最近升级了下linux服务器配置,重启之后,发现要敲一堆命令行,挺麻烦的,能开启自启动就好了 参考资料:在Linux中利用Service命令添加系统服务及开机自启动 Linux下设置nginx开机自动启动...1 编写服务启动脚本 编写一个脚本,然后把它放在/etc/init.d这个目录下,再用service + 脚本名字 运行即可 linux 下可以通过vim创建脚本然后添加脚本内容,我个人比较喜欢直接在...windows上创建好,然后用winscp上传到服务器上面(需要注意windows和linux特殊字符的问题) vim /etc/init.d/nginx 脚本内容如下:官方文档 #!...service nginx start 启动 service nginx restart 重启 service nginx stop 停止 如果执行没有问题就可以通过chkconfig 命令设置开机启动...6 扩展(docker自启动) 见资料:docker 设置容器开启自启动(无须写脚本) ---- 标题:Nginx学习日志(六)Linux下设置开机自启动 作者:hjljy 地址:https:/

    3.5K10

    nginx 启动错误 nginx: host not found in upstream

    简述 利用nginx进行反向代理的时候,我们会配置proxy_pass。在启动nginx的时候,会报错。...nginx 启动错误 nginx: [emerg] xxoo.pusdn.com host not found in upstream 前情提示 系统:centOS 一说 同步更新最新版、完整版请移步...部分截图、链接等因过期、更换域名、MD语法等可能不显示,可联系反馈(备注好博文地址),谢谢❤ 带有#号、删除线、不操作、不执行字样的为提示或者备份bash,实际不执行 利用nginx进行反向代理的时候...在启动nginx的时候,会报如下错误: nginx: [emerg] host not found in upstream "a.pusdn.com" in /usr/local/nginx/conf/...vhost/nginx.com.conf:36 解决: vi /etc/hosts 127.0.0.1 www.pusdn.com

    2.5K31
    领券